Реклама на этом месте
Форум 1С
Форум 1С
Programmers. Accountants. Administrators
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
06 Mar 2021, 16:55
Login with username, password and session length
МультиВход
Welcome, Guest. Please login or register.
Did you miss your activation email?
 
collapse

Author Topic: как правильно записать движения в регистр с модуля формы?  (Read 926 times)

0 Members and 1 Guest are viewing this topic.

Offline Yamuna

  • *
  • Posts: 23
  • РЕПУТАЦИЯ: 0
  • Register: 2016-04-19
  • Website: 
  • Профессия: Ученик 1С
Добрый день! подскажите плиз как надо сделать.. есть старое дополнение для Бухгалтерии Предприятия 2.0 учет ИТС, для Бухгалтерии 3.0 ее нет, и ее сейчас переписываем на Бух 3.0 и в модуле формы документа есть процедура которая из ТаблицыЗначений(АутентификационныеДанные) ,которая является реквизитом формы, получает данные и записывает в регистр вот код:
Code: [Select]
Процедура ЗаписатьАутентификационныеДанные()

МенеджерЗаписи = РегистрыСведений.ИТС_АутентификационныеДанные.СоздатьМенеджерЗаписи();
Для Каждого Строка Из АутентификационныеДанные Цикл

Если ЕстьПодпискиКонтрагента(Строка.Контрагент) Тогда

МенеджерЗаписи.Организация = Организация;
МенеджерЗаписи.Контрагент  = Строка.Контрагент;

МенеджерЗаписи.Прочитать();

Если Не МенеджерЗаписи.Выбран() Тогда
МенеджерЗаписи.Организация = Организация;
МенеджерЗаписи.Контрагент  = Строка.Контрагент;
КонецЕсли;

МенеджерЗаписи.Логин       = Строка.Логин;
МенеджерЗаписи.Пароль      = Строка.Пароль;

МенеджерЗаписи.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

и чтобы в управляемом приложении это реализовать надо таблицуЗначений сделать реквизитом документа? и потом в модуле документа проводку делать? или можно и в модуле формы с директивой компиляции &Насевере? как лучше?


Tags:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

* Статьи

* Кто онлайн

  • Dot Guests: 56
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Search

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal