Реклама на этом месте
Форум 1С
Форум 1С
Programmers. Accountants. Administrators
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
04 Mar 2021, 19:23
Login with username, password and session length
МультиВход
Welcome, Guest. Please login or register.
Did you miss your activation email?
 
collapse

Author Topic: как из документа загрузить данные в таличную часть?  (Read 685 times)

0 Members and 1 Guest are viewing this topic.

Offline Yamuna

  • *
  • Posts: 23
  • РЕПУТАЦИЯ: 0
  • Register: 2016-04-19
  • Website: 
  • Профессия: Ученик 1С
Добрый день! подскажите как из документа который я выбираю из табличной части другого документа,загрузить данные в табличную часть в управляемом приложении. в табличной части есть реквизит "Заявка" с типом ссылкой на докумен который надо отобразить и не пойму как надо сделать..


Offline Yamuna

  • *
  • Posts: 23
  • РЕПУТАЦИЯ: 0
  • Register: 2016-04-19
  • Website: 
  • Профессия: Ученик 1С
Добрый день! подскажите как из документа который я выбираю из табличной части другого документа,загрузить данные в табличную часть в управляемом приложении. в табличной части есть реквизит "Заявка" с типом ссылкой на докумен который надо отобразить и не пойму как надо сделать..
с этим уже разобрался и еще есть вопрос: необходимые поля сейчас в таб часть выбираются когда я выбираю еще один документ то он выбирается и перезаписывает старый вместо того чтоб добавить еще один.это наверное происходит из за того что я выбрал событие обработкаВыбора реквизита табличной  части? я не смог найти событие для табличной части которое бы срабатывало, проверял отладчиком. или тут надо создавать свою кнопку ? 
Добавлено: 27 Aug 2019, 11:56

Добрый день! подскажите как из документа который я выбираю из табличной части другого документа,загрузить данные в табличную часть в управляемом приложении. в табличной части есть реквизит "Заявка" с типом ссылкой на докумен который надо отобразить и не пойму как надо сделать..
с этим уже разобрался и еще есть вопрос: необходимые поля сейчас в таб часть выбираются когда я выбираю еще один документ то он выбирается и перезаписывает старый вместо того чтоб добавить еще один.это наверное происходит из за того что я выбрал событие обработкаВыбора реквизита табличной  части? я не смог найти событие для табличной части которое бы срабатывало, проверял отладчиком. или тут надо создавать свою кнопку ?
похоже что выгрузка в табличную часть перезаписывает ее полностью, а как записать данные в новую строку таб части?
Code: [Select]
&НаСервере
Процедура ОбработкаНаСервере(Ссылка)


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИТС_ВходящаяЗаявка.ДатаНачала КАК ДатаНачала,
| ИТС_ВходящаяЗаявка.ДатаЗавершения КАК ДатаЗавершения,
| ИТС_ВходящаяЗаявка.ВидПодписки КАК ВидПодписки,
| ИТС_ВходящаяЗаявка.Контрагент КАК Контрагент,
| ИТС_ВходящаяЗаявка.Ссылка КАК Заявка,
| ИТС_Подписки.СостояниеЗаявки КАК СостояниеЗаявки
|ИЗ
| Документ.ИТС_ВходящаяЗаявка КАК ИТС_ВходящаяЗаявка
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ИТС_Подписки КАК ИТС_Подписки
| ПО ИТС_Подписки.Регистратор = ИТС_ВходящаяЗаявка.Ссылка
| И ИТС_Подписки.Заявка = ИТС_ВходящаяЗаявка.Ссылка
|ГДЕ
| ИТС_ВходящаяЗаявка.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Ссылка);

Результат = Запрос.Выполнить().Выгрузить();
     Объект.Подписки.Загрузить(Результат);
КонецПроцедуры // ОбработкаНаСервере(ВыбранноеЗначение)()



&НаКлиенте
Процедура ПодпискиПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
ОткрытьФорму("Документ.ИТС_ВходящаяЗаявка.Форма.ФормаВыбора1",,Элемент);
КонецПроцедуры

&НаКлиенте
Процедура ПодпискиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Отбор= Новый Структура( "Заявка",ВыбранноеЗначение );
Строка = Объект.Подписки.НайтиСтроки(Отбор);
Если  Строка.количество() > 0 Тогда
ИТС_ОбщегоНазначения.СообщитьОбОшибке("Добавление выбором не выполнено.
         |Выбранная заявка уже присутствует в табличной части");
Возврат;
КонецЕсли;
ОбработкаНаСервере(ВыбранноеЗначение);
КонецПроцедуры

Last Edit: Yamuna; 27 Aug 2019, 11:56. Reason: Merged DoublePost


Tags:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

* Статьи

* Кто онлайн

  • Dot Guests: 63
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Search

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal